Daily Lucky Numbers:
15
21
24
26
38
39

Odd behaviour with a game

Started by Dave, February 16, 2024, 05:21:45 PM

Previous topic - Next topic

Dave

I have downloaded a game which used to be on my site but or some reason it stopped working. The game is attached. Now what happens on both Brave and Firefox browsers is that the games goes to start and then all I get is the music but no animation.

Anyone have any ideas what it might be?

I should add that I have downloaded and installed a few of the same game from different sites with the same issue. The game plays perfectly on one of the sites, but I didn't test in on all of them.

I did download the version from here (and that is currently installed on my site) and the same thing happens with that too. I can't test yours as it says that flash is not installed

Update: I have now tried to play this on Ronald's arcade and next level arcade with the same results. On next level it says that there is a ruffle error, on Ronald's it does the same there as it does on mine which is just play the music
If you want play quizzes or games click below

Listen to Quizland radio here

Chen Zhen


There's something up with the Ruffle Github page.

Go to arcade maintenance for the Ruffle update, opt the override checkbox & select the WebDev file.
It will say that it's forcing the opted file which is from July 2023.

This will allow the game to work.

Dave

Quote from: Chen Zhen on February 16, 2024, 05:39:33 PMThere's something up with the Ruffle Github page.

Go to arcade maintenance for the Ruffle update, opt the override checkbox & select the WebDev file.
It will say that it's forcing the opted file which is from July 2023.

This will allow the game to work.


OK thanks Chen I'll try it
If you want play quizzes or games click below

Listen to Quizland radio here

Dave

On Quizland I get the following error when I try to update it

array(2) { [0]=> array(3) { ["file"]=> string(70) "/**********/domains/quizland.co.uk/public_html/Sources/Errors.php" ["line"]=> int(301) ["function"]=> string(9) "log_error" } [1]=> array(1) { ["function"]=> string(17) "smf_error_handler" } } Error loop.
On the test site I get a 500 page error
If you want play quizzes or games click below

Listen to Quizland radio here

Dave

It's bed time here I'll have a look tomorrow to see if one of the previous versions on the arcade has that version of Ruffle in it, if it has then I'll upload the files and let you know what happens.
If you want play quizzes or games click below

Listen to Quizland radio here

Chen Zhen


It's working on this site & my localhost so perhaps its related to PHP download file size settings.



I checked the Ruffle website & they changed things so I'll have to update the arcade for retrieving their updated file.
There is the option of downloading it from their site & uploading it manually in the admin page.
This still won't work until you adjust your PHP settings.

Chen Zhen


Actually the manual upload is failing at the moment..
I'll have to look at that as well.
All of this was working last I checked but not any more..  :-[

Dave

Quote from: Chen Zhen on February 16, 2024, 05:52:26 PMThis still won't work until you adjust your PHP settings.


These are the host PHP settings

maxExecutionTime - 360s
maxFileUploads - 20
maxInputTime - 360
maxInputVars - 5000
memoryLimit - 1536
postMaxSize - 1536M
session.gcMaxlifetime - 1440s
uploadMaxFilesize - 1536M
If you want play quizzes or games click below

Listen to Quizland radio here

Dave

I have now determined that the issue lies with the game. I have installed ruffle from all different times and I can get other flash games to work but not that spear toss. The only version I can get working is the one attached to this post
If you want play quizzes or games click below

Listen to Quizland radio here