January 22, 2022, 10:25:50 PM

Daily Lucky Numbers:
7
16
24
31
38
43

Recent posts

Pages 1 ... 8 9 10
91
SMF Arcade Support + Plugins / Re: Mobile compatibility
Last post by Dave - August 14, 2021, 05:36:26 AM
Quote from: Dave on August 14, 2021, 05:35:23 AMHi all,

I occasionally use my Samsung Tab S6 to play games on my site if I'm out and about. When I log in to the site I go to Arcade and the layout is huge and virtually all white (and I've tested it here too). I've attached a couple of screenshots so you can see it. It happens on all themes even the SMF default.

If I click on the 'View desktop site' option on the tablet it then shows as normal.

Now I'm not sure if this is an SMF issue or if it's the Arcade. The Quiz works as normal as does everything else.

Anyone have any idea what might cause this?

Screenshot_20210814-082300_Edge.jpg

Dave




Sorry I should have resized the attachment  :-[
92
SMF Arcade Support + Plugins / Mobile compatibility
Last post by Dave - August 14, 2021, 05:35:23 AM
Hi all,

I occasionally use my Samsung Tab S6 to play games on my site if I'm out and about. When I log in to the site I go to Arcade and the layout is huge and virtually all white (and I've tested it here too). I've attached a couple of screenshots so you can see it. It happens on all themes even the SMF default.

If I click on the 'View desktop site' option on the tablet it then shows as normal.

Now I'm not sure if this is an SMF issue or if it's the Arcade. The Quiz works as normal as does everything else.

Anyone have any idea what might cause this?

Screenshot_20210814-082300_Edge.jpg

Dave

93
SMF Arcade Support + Plugins / Re: Theme issue
Last post by Dave - August 14, 2021, 03:03:29 AM
Quote from: Chen Zhen on August 13, 2021, 08:27:04 PMUninstall that theme and upload the new file that is attached to this post.
I figured out exactly what was causing all the white space in the admin and fixed it properly this time.

All done thanks UD.

Again give me a link to be able to donate a beer to the cause please.

Dave
94
SMF Arcade Support + Plugins / Re: Theme issue
Last post by Chen Zhen - August 13, 2021, 08:27:04 PM

Uninstall that theme and upload the new file that is attached to this post.
I figured out exactly what was causing all the white space in the admin and fixed it properly this time.
95
SMF Arcade Support + Plugins / Re: Theme issue
Last post by Dave - August 09, 2021, 01:28:23 AM
Quote from: Chen Zhen on August 08, 2021, 08:50:31 PMI installed the latest RC of the Arcade on your website and the flash games appear to be working fine now using that theme.
It has a recent nightly build version of the emulator built in among some other additions and fixes.

Let me know if it's also working for you now.

Brilliant UD everything is working as it should. I have also re-instated the portal blocks and it's still ok.

Thank you very much

regards

Dave
96
SMF Arcade Support + Plugins / Re: Theme issue
Last post by Chen Zhen - August 08, 2021, 08:50:31 PM

I installed the latest RC of the Arcade on your website and the flash games appear to be working fine now using that theme.
It has a recent nightly build version of the emulator built in among some other additions and fixes.

Let me know if it's also working for you now.
97
SMF Arcade Support + Plugins / Re: Theme issue
Last post by Dave - August 08, 2021, 05:20:25 PM
Quote from: Chen Zhen on August 08, 2021, 03:42:20 PMOops.. I forgot to change the theme.

I see an error because of something called Highslide.
Is this from a mod or a block?

It appears there is a Highslide mod on the mod site.
Did you by any chance uninstall this mod but perhaps left edits or hooks from it by not properly uninstalling it?
It is trying to use its file(s) but they are not available.


Highslide was on the site and I uninstalled it earlier today as it's heavily JS, which is what the ruffle error seems to be saying. But it works on the test site. So far the test site is near enough identical, as far as mods are concerned, and everything works OK.

I see you've signed up so I will make you admin so you can see more.

Again it's bedtime here so I'll resume tomorrow.

Thanks for looking at it UD

Regards

Dave
98
SMF Arcade Support + Plugins / Re: Theme issue
Last post by Chen Zhen - August 08, 2021, 03:42:20 PM
Oops.. I forgot to change the theme.

I see an error because of something called Highslide.
Is this from a mod or a block?

It appears there is a Highslide mod on the mod site.
Did you by any chance uninstall this mod but perhaps left edits or hooks from it by not properly uninstalling it?
It is trying to use its file(s) but they are not available.
99
SMF Arcade Support + Plugins / Re: Theme issue
Last post by Chen Zhen - August 08, 2021, 03:38:20 PM

It's working for me and I just saved a score on that linked game.
Did you press the big play button that shows up in the container?
100
SMF Arcade Support + Plugins / Re: Theme issue
Last post by Dave - August 08, 2021, 07:15:05 AM
Quote from: Dave on August 08, 2021, 02:38:58 AM
Quote from: Chen Zhen on August 07, 2021, 07:54:56 PMBtw it still uses the Motools plugin  but I updated it and also adjusted the theme's CSS file. It should work good now but I didn't test everything.

It does work good now. I have tested it on my test sites with both ruffle games and H5 and it's working Ok with no errors in the log or anywhere else for that matter.

Thank you very much UD you're help is much appreciated.

As previously mentioned give me a link to donate please?

regards

Dave

Well I don't know why but when I install it on my live site 'Quizland' for some reason it gives a ruffle error for any flash game I try to play, H5 games are OK. That didn't happen on the test site and I have the same mods installed on both.

Looking at the 'browser inspect' on the site the only difference between the two is a red error which is related to '@-moz-keyframes scroll-left { }'.

The ruffle error is:

# Error Info
Error name: TypeError
Error message: WebAssembly.instantiate(): Argument 0 must be a buffer source or a WebAssembly.Module object
Error stack:
```
TypeError: WebAssembly.instantiate(): Argument 0 must be a buffer source or a WebAssembly.Module object
    at https://www.quizland.co.uk/******/******/ruffle.js:1:33693
    at n (https://www.quizland.co.uk/******/******/ruffle.js:1:33776)
```

# Player Info
Allows script access: true
Player type: Object
SWF URL: https://www.quizland.co.uk/******/******/MakaiSpearToss_v32.swf
Attribute 0: undefined
Attribute 1: undefined
Attribute 2: undefined
Attribute 3: undefined
Attribute 4: undefined
Attribute 5: undefined

# Page Info
Page URL: https://www.quizland.co.uk/index.php?action=arcade;sa=play;game=330

# Browser Info
Useragent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.131 Safari/537.36 Edg/92.0.902.67
OS: Win32

# Ruffle Info
Version: 0.1.0
Name: nightly 2021-07-14
Channel: nightly
Built: 2021-07-14T00:12:43.820Z
Commit: f9be5c2230b190549150a1cf058cbb284f6e36d8

It's OK on other themes by btw, I have left it installed so it can be checked. I have reverted back to the old theme but themes can be changed by guests if anyone wants to look

Regards

Dave



Pages 1 ... 8 9 10