Daily Lucky Numbers:
5
13
14
31
34
38

Error Log Control mod problems

Started by Shades, March 16, 2023, 05:59:55 PM

Previous topic - Next topic

Shades

Hello,

I have the ErrorLogControl mod v1.3 installed on SMF 2.1.3 and have "Enable reporting of failed password log-in attempts" ticked but not getting ay error messages when I try to login with wrong password. I uninstalled the mod and the password failed attempt new errors show up but no previous error messages from the earlier failed password attempt. Any ideas?

LogSettings.png

Thanks,
Shades 8) 
ShadesWeb.com - Custom Logos & SMF Themes
BikerHound.com - Motorcycle Events

Dave

Shades,

Just a thought, do you have the error logging enabled in Admin>Maintenance>Logs>Log Settings?

I'm not sure if 'Error Log Control' would override that, and maybe if they are enabled then disable them and test again

Dave

Shades

Quote from: Dave on March 17, 2023, 04:20:42 AMShades,

Just a thought, do you have the error logging enabled in Admin>Maintenance>Logs>Log Settings?

I'm not sure if 'Error Log Control' would override that, and maybe if they are enabled then disable them and test again

Dave

Yes, as seen in my attachment above. ;)
ShadesWeb.com - Custom Logos & SMF Themes
BikerHound.com - Motorcycle Events

Shades

Also when entering an incorrect password it should take me to the password incorrect page but it doesn't.

passwordincorrect.png

Instead it take me to the Authentication Reminder page.

AuthenticationReminder.png

The images above are from a new test site and different from my OP, just so you know, and same issue! ;)

Thanks,
Shades 8)
ShadesWeb.com - Custom Logos & SMF Themes
BikerHound.com - Motorcycle Events

Dave

Quote from: Shades on March 18, 2023, 08:54:55 AM
Quote from: Dave on March 17, 2023, 04:20:42 AMShades,

Just a thought, do you have the error logging enabled in Admin>Maintenance>Logs>Log Settings?

I'm not sure if 'Error Log Control' would override that, and maybe if they are enabled then disable them and test again

Dave

Yes, as seen in my attachment above. ;)

Ah the reason I mentioned that is because my view of that is different to yours, it must be the 'Error Log Control' mod that adds to the default SMF settings.

So just ignore me :)

Dave

Another thought...as I'm prone to having them...


the last update for that mod was 19/08/22; could it be a PHP8 issue?

Shades

Quote from: Dave on March 18, 2023, 09:22:22 AMAnother thought...as I'm prone to having them...


the last update for that mod was 19/08/22; could it be a PHP8 issue?
Hmm...never thought of that! Will test and see and report back. ;)

I'm not able to come to this site often cause I have to use a browser with a VPN (like Opera & I hate Opera lol) to visit webdev for some reason so sorry if it takes me some time to respond.

Thanks,
Shades 8)
ShadesWeb.com - Custom Logos & SMF Themes
BikerHound.com - Motorcycle Events

Shades

Oh well, that didn't work either! Acts the same when I switched to PHP: 7.4.33 as it does with PHP: 8.0.28 so that's not the problem! :(
ShadesWeb.com - Custom Logos & SMF Themes
BikerHound.com - Motorcycle Events

Dave

Quote from: Shades on March 21, 2023, 10:26:07 PMI'm not able to come to this site often cause I have to use a browser with a VPN (like Opera & I hate Opera lol) to visit webdev for some reason so sorry if it takes me some time to respond.

Thanks,
Shades 8)

That's strange as the same thing used to happen to me on 'SMFH' until they moved hosts, now it's OK. Apparently there was a block on my service provider 'Virgin' which was picked up by mod_security for some reason