Daily Lucky Numbers:
4
13
23
26
34
43

Recent posts

#21
EhPortal Support / Re: Top Poster Block showing d...
Last post by Chen Zhen - October 05, 2022, 09:37:39 PM

Alright.. my mistake as registration is enabled on your forum.
I'm taking a look at it now.
#22
EhPortal Support / Re: Top Poster Block showing d...
Last post by Chen Zhen - October 05, 2022, 09:16:53 PM

The last attachment has an update for Gravatars since I neglected to previously support them which I thought might be the issue.
I've tested it with default forum avatars, uploaded avatars, external source avatars & gravatars whereas all seem to work without issue.

At the moment you have registration disabled on your climbing forum..
If you want I can take a look at the home page with the block on it so I can try to see what's going on.
Looking at the HTML of the page will allow me to see what URL's it's using for the avatars that aren't working properly.
If you create a temporary user with access & PM me some credentials then I'll take a look.
#23
EhPortal Support / Re: Top Poster Block showing d...
Last post by Gus A - October 05, 2022, 08:45:18 PM
Hey Chen,

Can't thank you (and Dave) enough for the prompt support.

Just update EhPortal with EhPortal_v1.39. No luck.

For what it's worth, avatars are showing up for these people elsewhere in the forum, just not in top posters. t
When clicked, the "broken" avatars seem to link to the correct profile.

Not sure if this info helps.

#24
EhPortal Support / Re: Top Poster Block showing d...
Last post by Chen Zhen - October 05, 2022, 06:08:46 PM
Try updating EhPortal with the attachment & let me know if it fixes your issue.
#25
EhPortal Support / Re: Top Poster Block showing d...
Last post by Gus A - October 05, 2022, 08:29:10 AM
Hey Dave,

All good tips – thanks!

The site on the browser address bar shows it's https, but I'll double-check. I'll also run the repair_permissions file and let you know what comes up!

 
#26
EhPortal Support / Re: Top Poster Block showing d...
Last post by Dave - October 04, 2022, 09:47:35 AM
Hi Gus,

I'm not sure if this will relate to you or not, but on my NAS drive I installed a version of SMF2.1 and then loaded up the portal and various other things to test.

Whilst doing that I had the same issue you have and found out it was related to the site not being secure...i.e. https://.

The reason some avatras may be showing up is bacause they are either uploaded avatars and stored in the 'custom_avatar' folder or they are in the direct 'avatar' folder.

Try running repair_settings.php which I have attached here.

Not sure if you know how to run it but just upload the file to the root of your site and then type in your browser https://www.mysite.com/repair_settings.php

Check out the top most settings first and enable the recommended settings, then go to the bottom and click on '[Restore all settings]' this will change any of the error paths and you'll see them in red after the button has been pressed. Check that they are the correct paths to the folders then click on 'Save Settings' and hopefully that might fix it.

A little tip also, when you're finished with the repair_settings.php file don't delete it, just remove the hp from the .php so it looks like 'repair_settings.p' this way if you ever need to use it again for any reason all you need to do is rename it again instead of finding it and uploading it again.

I hope that helps

#27
EhPortal Support / Re: Top Poster Block showing d...
Last post by Gus A - October 04, 2022, 09:07:45 AM
Thanks for the quick response!

I installed v1.38 and it seems to have fixed the duplicates but the avatars are still not showing.

Screen Shot 2022-10-04 at 9.03.04 AM.png

Also, when I uninstalled the previous version, I did not "Remove all data associated with this modification." I assume that is correct?

Screen Shot 2022-10-04 at 9.05.55 AM.png
#28
EhPortal Support / Re: Date error
Last post by Dave - October 04, 2022, 02:55:29 AM
Thanks Chen it's works fine now
#29
EhPortal Support / Re: Date error
Last post by Chen Zhen - October 03, 2022, 07:39:21 PM
I never noticed it this whole time & it's right in my face on my localhost sites (it never affected this Waverider template).
Thanks for reporting it!!

This is now fixed and released.
#30
Battle Support / Re: How to make gold?
Last post by Chen Zhen - October 03, 2022, 07:35:52 PM

You can set the currency type/name in Battle admin.
There are also settings for the frequency at which you want to have gold added to user accounts (ie. daily, weekly, etc.).
"Gold" (the default currency) can also be acquired via quests which you create in the Battle admin.
There are changes coming to this in the next major release where gold can be acquired battling monsters.
This will be implemented with admin settings so that the site owner/admin can dictate how it plays out.

As for the Arcade.. that sounds like a decent request.
I can also add it for the next major Battle release.. It will be a setting in Battle if it detects the Arcade.
The Arcade already has score hooks so it can tap into those.