Daily Lucky Numbers:
16
22
24
33
47
49

SMF Arcade 2.6.7 - Stable -> Released!

Started by Chen Zhen, February 12, 2022, 01:00:13 AM

Previous topic - Next topic

Chen Zhen


I can always fix the older shoutbox if you really like it.
Unless the TP shoutbox is ok.
You might need to edit the user permissions for that TP shoutbox because I was only able to read the shouts.

Dave


FrizzleFried

Oddly... I can play flash games without issue,  but I can not play any H5 games.  Is there something I need to do to configure my system to play H5 games?

Dave

I get the errors shown in the error log attached from guests. Now I'm not sure if this is an SMF issue or an Arcade issue (it references arcade;ssl in the error). The settings I have for SSL are as seen below

I'm going to temporarily disable ssl and see what happens.

Chen Zhen

My apologies for the late replies as I have been preoccupied with other things.

@FrizzleFried:
As long as you're using an up-to-date browser then it should work fine.
Other things on the arcade page from mods or manual edits can sometimes conflict with JavaScript which may cause your problem.
If the HTML5 game plays here on this arcade then download it and try it on your arcade.
If it doesn't work then on that arcade page you can right-click & inspect (developer mode) the page in your browser.
Use the "console" option to view JavaScript errors. This will likely provide clues as to what is wrong.

@Dave:
I will investigate your report although this does not occur on this forum.
However I may have different settings for guests.

FrizzleFried

New SMF 2.1.1 install with only 12 mods running (mostly with hooks)...

New browser (of course).

Flash games work great (95% of them anyway).

HTML 5 games... just a blank screen.

I've downloaded the HTML 5 pack here thinking maybe I had the wrong ones.... same result.

I am at a loss.

I'll check the developer console.  Thanks.

Chen Zhen


I can take a look myself if it's a live arcade forum.
The only link I see on SMF forum's under your user-name points to idahogaragecade but I don't know the sub-path to a possible SMF forum if one exists.

FrizzleFried

This is the error I am getting in the console when I run a HTML5 game downloaded from a gamepack here in it's own window...

QuoteMixed Content: The page at 'https://www.aha-forums.com/index.php?action=arcade;sa=play;game=307;pop=1;full=0'; was loaded over HTTPS, but requested an insecure frame 'http://www.aha-forums.com/Games/2048/2048.html';. This request has been blocked; the content must be served over HTTPS.

Now,  looking at it,  I went in and noticed that my setting for URL TO GAMES setting in the Arcade Admin section had HTTP:// versus HTTPS:// ...

A switch to HTTPS:// and... HTML5 games are working!!

Woo hoo!

:)

Dave

Quote from: FrizzleFried on March 14, 2022, 10:40:02 AMThis is the error I am getting in the console when I run a HTML5 game downloaded from a gamepack here in it's own window...

QuoteMixed Content: The page at 'https://www.aha-forums.com/index.php?action=arcade;sa=play;game=307;pop=1;full=0'; was loaded over HTTPS, but requested an insecure frame 'http://www.aha-forums.com/Games/2048/2048.html';. This request has been blocked; the content must be served over HTTPS.

Now,  looking at it,  I went in and noticed that my setting for URL TO GAMES setting in the Arcade Admin section had HTTP:// versus HTTPS:// ...

A switch to HTTPS:// and... HTML5 games are working!!

Woo hoo!

:)

Good news FF

Dave

#24
I have just noticed that the search function in 2.6.7 in the Arcade>Admin>Edit Games, doesn't seem to work at all, not even an error.

As you will see from the screenshot, I searched for 'Aquacubes' which I know is there, but the screen just reverted to the default first page.