WebDev

SMF Arcade => SMF Arcade Support + Plugins => Topic started by: Kone on August 25, 2020, 03:11:55 AM

Title: Can’t access admin settings for Arcade
Post by: Kone on August 25, 2020, 03:11:55 AM
Excellent mod btw... I'll installed the latest stable version 2.26.12 and everything installed fine, but when I access the arcade admin settings, every link give me an error. I've attached a screenshot of the admin settings. I also get an error for the admin games settings.
Title: Re: Can’t access admin settings for Arcade
Post by: Kone on August 25, 2020, 03:42:23 AM
Sorry I meant 2.56.12 not 2.26.12
Title: Re: Can’t access admin settings for Arcade
Post by: vince on August 25, 2020, 04:43:33 PM
What php version you running ? If it's prior to 5.5 I think that may have something to do with it
Title: Re: Can’t access admin settings for Arcade
Post by: vince on August 25, 2020, 04:49:54 PM
Sounds like php 5.4
Title: Re: Can’t access admin settings for Arcade
Post by: Chen Zhen on August 28, 2020, 11:46:18 PM
You will need PHP 5.6 or a higher version to use this modification.
I recommend updating your PHP version to 7.1 or higher.

The latest stable PHP version at the time of this post is PHP 7.4.9 which means PHP 7.5.0 is likely to be released very shortly.
In my opinion no host should be providing any PHP version previous to the PHP 7 branch.
Although some hosts leave it up to the customer to upgrade via a control panel such as CPanel or Plesk.

Anyone running a VPS or Dedicated server would likely know to upgrade PHP on their own via a terminal.
I will put a notification in the readme regarding the minimal PHP version and recommended PHP version.
Title: Re: Can’t access admin settings for Arcade
Post by: Kone on August 29, 2020, 02:48:39 AM
Thank you for your replies. I think I'm on PHP version 7.3.6 any other suggestions of what the problem could be?

IMG_2646.jpg
Title: Re: Can’t access admin settings for Arcade
Post by: Chen Zhen on August 29, 2020, 05:37:04 PM
The error you describe should only occur in PHP versions prior to 5.5.
If you are indeed using PHP 7.3, the error should not occur.

To test what PHP version you are using you can do the following:

Install a portal modification (ie. Simple Portal).
Create a PHP type block and enter the following code for the block:

echo '<div style="font-size: 1.2em;">', phpinfo(), '</div>';

You can preview the block or save it and view it on your portal.
(Imo do not keep it viewable to your users though)

This will show the PHP version which I suspect is older than you think.
EhPortal 1.28 © 2020, WebDev