July 04, 2020, 09:15:00 pm

Recent posts

Pages 1 2 3 4 ... 10
11
SMF Arcade Support + Plugins / Re: SMF Arcade 2.57.0-beta12
Last post by Chen Zhen - June 12, 2020, 06:17:10 pm

Great that should work out much better for you instead of the current stable.
With the beta packages, check back here every few weeks or so to see if I release another beta.
I will likely be releasing one this weekend.
A stable version is very close but there are still some things to work out and my time for development is a little sparse.
Too much to do around the house plus I have been working this whole time during the Covid-19 outbreak so I get a bit tired.

I will keep your requests in a to-do list but the next stable version is overdue so I have to work on getting it out without adding anything else. The change log is already very lengthy.
 

12
Releases & Version Updates / Re: Lepido Smileys
Last post by ice - June 10, 2020, 12:50:09 pm
thanks for the smileys
13
SMF Arcade Support + Plugins / SMF Arcade 2.57.0-beta12
Last post by Ronald - June 09, 2020, 08:35:42 pm
I have installed the beta 12 arcade..

If possible can you add the following to the arcade. Would be nice to have the following added

1.Arcade Announcements
2.Game Of The Day Challenge
3.Game Of The Week Challenge
4.Game Of The Month Challenge
5.Team Challenge
14
Spamblocker / Re: SMF 2.0.14 Error
Last post by Chen Zhen - June 01, 2020, 02:50:57 pm

No it's the Spam Police mod.
It usually just stops new people from posting if they post links.
I will look into adjusting its settings.
15
Spamblocker / Re: SMF 2.0.14 Error
Last post by Skhilled - June 01, 2020, 09:58:58 am
Yup, got fixed yesterday. Update is in the downloads. :)

@Chen - Les may have got blocked by the spam blocker and I approved his post. Maybe cause he was using his VPN. Now he can't post or anything.
16
Spamblocker / Re: SMF 2.0.14 Error
Last post by lesmond - June 01, 2020, 07:27:55 am
Did this ever get fixed?

I am getting the same error on a site I manage

http://xxxx.com/forums/index.php?action=register2
Only variables should be passed by reference
File: /home/xxxx/public_html/forums/Sources/SpamBlocker.php
Line: 286

SMF 2.0.17 php 7.2
17
SMF Arcade Support + Plugins / Re: File failed to load: 0 byt...
Last post by Chen Zhen - May 31, 2020, 10:41:12 pm

The script for uploading is working fine on this site & doc skillz which is why I failed to see the issue.
Recently I created 2 fresh test forums (using both SMF versions) and have found there is an issue with the upload script.

What you can do until it is fixed is use FTP to upload the compressed game files to your "Games" directory.
From that point you can install the games from the Arcade admin section & they should work fine.
This issue will be fixed in the upcoming release.

Thank you for reporting the problem.
18
SMF Arcade Support + Plugins / Re: File failed to load: 0 byt...
Last post by Chen Zhen - May 07, 2020, 04:29:06 pm

Also 755 permission setting is very important rather than 777.
For it to work correctly you need the proper ownership set on the forum directory in the first place.
Your forum directory should be set to apache ownership.
The command to set that will depend on your Distro.
Although if you have a control panel such as Plesk or CPanel, there should be an option to set that or fix ownership & permissions.

19
SMF Arcade Support + Plugins / Re: File failed to load: 0 byt...
Last post by Chen Zhen - May 07, 2020, 04:16:58 pm

The Arcade utility you referenced in #1 creates the .htaccess file for you.
In your case you you click on the Apache option & press save.
It puts the .htaccess file in the Games directory.
If you think the .htaccess file it creates is causing the problem then you can use the delete option to remove it.
Again, this only concerns a .htaccess file located in your Games directory.


Try what Skhilled suggests regarding permissions and ownership.
Something is awry with your settings if it is not letting website PHP files access folders or adjust permissions.
Although the line you referenced checks if it's writable to begin with.
20
SMF Arcade Support + Plugins / Re: File failed to load: 0 byt...
Last post by Skhilled - May 06, 2020, 09:46:20 am
@grandseb59, Try setting your directories to 755 and files to 644 and see if that works. If not, you may need to ask your hosting to check ownership of the directories and files (chown). If you are on a VPS or dedicated server then you should be able to fix it yourself.

To change ownership (chown) run the following two lines of code in SSH. Replace "username" with your hosting name:

cd /home/username

chown -R username:username public_html

To change permissions (chmod) run these two lines of code in SSH:

find . -type d -print0 | xargs -0 chmod 0755 # For directories

find . -type f -print0 | xargs -0 chmod 0644 # For files

Or change the numbers to whatever your server is supposed to be.
Pages 1 2 3 4 ... 10