Snowflakes Not working

Started by Ronald, December 04, 2018, 02:07:34 pm

Previous topic - Next topic

Ronald

QuoteActually, must be different browsers or "something", I tried it and there isn't any snow on my tablet or using MS Edge or IE11

The above quote is from a member on my other forum, in fact I have two who say it doesn't work for them.

https://coffeetimeunlimited.com/index.php?topic=21819.new#new

Chen Zhen


They have an option in their profile to disable it.
Perhaps they have done that.

Chen Zhen


Also there is a permission setting for each membergroup that enables/disables the snowflakes.
The permission setting reads "Disable Snowflakes", meaning if it is checked then it is disabled for that membergroup.

Ronald

Quote from: Chen Zhen on December 04, 2018, 07:47:55 pmAlso there is a permission setting for each membergroup that enables/disables the snowflakes.
The permission setting reads "Disable Snowflakes", meaning if it is checked then it is disabled for that membergroup.


Permissions are set in place..

I explained in their profile under snowflakes they could disable or enable snowflakes..I don't know most of these people use ipads, and tablets, and have more problems than carter has liver pills.

Chen Zhen

Quote from: Chen ZhenThe permission setting reads "Disable Snowflakes", meaning if it is checked then it is disabled for that membergroup.

Perhaps you overlooked the above sentence.
That permission setting works opposite to what you think.
Ticking the check box for it disables the mod for that membergroup.
The text & help icon explain its function/usage.

I checked your other forum and you had the "Disable" option checked for most membergroups.
That has now been unchecked for most groups (except your auto-poster & account disabled groups).

Ronald

All permissions are good to go.. I take it some browsers will display snow flakes and some will not..

Ronald

The person who could not see the snow had the snow disabled..

Chen Zhen


Let me know which browser was showing a bad gateway error so that I can possibly trouble shoot.
Thanks.

Chen Zhen


Although that error is caused by an invalid response.
This could be the result of you making changes to the forum when users are attempting access.
It may not be related to the Snowflakes modification.

bigguy

After installing this on my site it breaks the news fader. Just installed it now. Have not played with settings yet.

bigguy

News fader works now if I check:

   Append to <body> of the HTML page.

Chen Zhen


Ya I'm glad I put that option in it long ago.
javascript tags can go in the head or body of the page so it should be ok.

I'm still going to take a look at your report though.
Thanks.

bigguy

Workin good now. Cool mod. I like the other effects as well. :)

Chen Zhen

If you read this thread, it'll give you a heads up regarding how the permissions for enabling it work.
Checking the "disable" permission for each membergroup will literally disable the mod for those groups.
It has to be unchecked to enable the effects.

Also I forgot to add the permission for the user profile option to the snowflakes admin page which I will add to the next version.
That permission is only available in your SMF permissions list for v1.41.
It will give each user the option to disable it which is good because some people do not want to see visual effects or sounds.

bigguy

I'm sure I have it set right. Do you see it.