Daily Lucky Numbers:

File failed to load: 0 byte file

Started by grandseb59, April 24, 2020, 09:43:09 AM

Previous topic - Next topic


good morning,
I'm currently on a SMF 2.0.17 forum.
and the arcade mod 2.56.12
When I try to install these games:


It returns this error to me:
File failed to load: 0 byte file

while others have settled in without a problem.
What do I have to do to get the games installed?

For your information, I tried by checking and unchecking the "Use HTML5 Upload Script" checkbox.

Thank you in advance for your help.

Chen Zhen

With that version of the arcade try not to use the .gz file download.
Opt zip or tar but do not use tar.gz ... it has an issue with larger files.
Always use the HTML5 upload script if possible.
Let me know if that solved the problem.


So I did what you told me to do, I unzipped the .tar and created a .zip
I checked the html5 box in the admin panel of the arcade.
and when I try to load it by the "browse" button, it doesn't load it.
If I "drop" it, it downloads it to my computer.

Then I uncheck the html5 box.
The game has loaded, I installed it... but it doesn't work ... :(


In fact, only the donkeykong settles but doesn't work, the others return the same error.

Chen Zhen

I fixed a lot of things in the latest beta although there are still many things pending.
You are welcome to try the latest beta which is available from my GitHub repositories.
Look for SMF Arcade 2.57

All the mods on that page are not updated but the Arcade is as of last night.



Does this beta version house the auto responsive feature we discussed in this topic? https://web-develop.ca/index.php?topic=493.0


for github, I didn't understand anything, there are a lot of files that always modify the same script...arcade.php

And besides, installing new games, made me appear full of error messages.
So I uninstalled it.
Maybe I'll see you soon.

Chen Zhen

April 26, 2020, 07:16:33 PM #7 Last Edit: May 14, 2020, 11:49:34 PM by Chen Zhen Reason: File removed
I wasn't sure if you knew how to deal with GitHub packages.
You can't just install it from the downloaded zip that you get from their site because it has sub-directories that the SMF installer does not take into account.

v2.5.7 of the arcade does deal with responsive layout although it is still in need of much work.
Mainly at this point the mobile games list template does not look proper in the SMF 2.0 branch but the game template is fine.

I will attach the beta here for a few days before removing it to make it easier for you.
Let me know if it fixes your game install problem.


Chen Zhen

Does the beta release allow you to install games now?


Sorry to answer so late
Actually, with beta 11, I can't load games anymore.

I am told that my "Games" folder is not writable and the CHMOD has failed. Please make it manually writable.

While I put everything in 777 with the recursion of subfolders and apply to all folders and files.

Chen Zhen

Try using Arcade maintenance from your admin section for creating a .htaccess file for X-Frame same origin.
Select the Apache option and save the setting.

If this does not work it is possible that you previously created the file & it is causing problems.
If this is the case you can use the option on that page to remove the file.


sometimes pictures speak better than words.
Here are some screens.

First of all, what you told me to do--
create an htaccess under apache after I did:
Delete: Remove any configuration files located in the directory.

But there are two problems:
1: You recommend installing the Mod Header.
What is it? and does it self-install when you install the arcade mod?
And if not, where to get it?

2: we created an htaccess file, but where should it be? I can't find it anywhere?

Then the error that always appears the same...

then proof that the chmod in the games folder is 777.

And the error log.


@grandseb59, Try setting your directories to 755 and files to 644 and see if that works. If not, you may need to ask your hosting to check ownership of the directories and files (chown). If you are on a VPS or dedicated server then you should be able to fix it yourself.

To change ownership (chown) run the following two lines of code in SSH. Replace "username" with your hosting name:

cd /home/username

chown -R username:username public_html

To change permissions (chmod) run these two lines of code in SSH:

find . -type d -print0 | xargs -0 chmod 0755 # For directories

find . -type f -print0 | xargs -0 chmod 0644 # For files

Or change the numbers to whatever your server is supposed to be.

Chen Zhen

The Arcade utility you referenced in #1 creates the .htaccess file for you.
In your case you you click on the Apache option & press save.
It puts the .htaccess file in the Games directory.
If you think the .htaccess file it creates is causing the problem then you can use the delete option to remove it.
Again, this only concerns a .htaccess file located in your Games directory.

Try what Skhilled suggests regarding permissions and ownership.
Something is awry with your settings if it is not letting website PHP files access folders or adjust permissions.
Although the line you referenced checks if it's writable to begin with.