Can not install H5 games

Started by Ronald, September 15, 2020, 02:19:49 PM

Previous topic - Next topic

Ronald

I trued installing some more H5 games, it will not install, just half blue circle and a red X

Ronald

I can not install any games, doesn't matter which type. Blue circle stops game name turns red and the red x appears.

Chen Zhen


There is something wrong with your cookie settings because a few times now I have had trouble logging in.

Are you running any sub-forums (testing or live) off of the main forum path?

Chen Zhen


I see one of your mods invokes an jquery load via document.write.
It is showing on the game upload page and might be causing a problem.

What is the most recent mod you installed before seeing these errors?

Chen Zhen


I tried uninstalling all your other mods to see if something was conflicting but had the same issue.
Then I just tried to go back to RC6 of the arcade but same problem.

RC7 works fine when I test uploading games via the HTML5 script in on SMF 2.0 & SMF2.1.

The one thing I keep seeing on your forum is some sort of cookie/session issue.
It repeatedly boots me out.

I tried messing with your cookie settings but it didn't fix it so I put them back to the default (the way it was before I made changes for a test).

In my opinion it's a cookie problem with your forum itself.
The HTML5 uploader splits a file into chunks so it can do large files because most HTML5 games are bigger than most flash games.
So in the background it's reloading the same page several times.
In doing that your forum is likely logging the user (you/me) out.

Something in your Apache settings has gone awry.
Also if you recently installed/enabled mod security you need to disable it.
The arcade will not work properly with that enabled.


Chen Zhen

You can try looking at your actual php error log from your website control panel (ie. CPanel, Plesk, etc.).
Try to see if there are errors from the arcade files within the last day.
Any error messages there might give us a clue as to what is causing the upload script to fail.

Ronald

Quote from: Chen Zhen on September 15, 2020, 06:14:01 PMYou can try looking at your actual php error log from your website control panel (ie. CPanel, Plesk, etc.).
Try to see if there are errors from the arcade files within the last day.
Any error messages there might give us a clue as to what is causing the upload script to fail.

About the cookies, I set it to 0, because ever time I made a move I'd have to sign back in, set to 0 and I didn't get logged out.

Errors
Mon Sep 14 17:06:59.132953 2020] [cgid:error] [pid 19585:tid 140334944012032] [client 114.119.147.240:28606] AH01265: attempt to invoke directory as script: /home/theoverg/rebelsarcade.com/cgi-bin/
[Sun Sep 13 17:09:34.316714 2020] [core:alert] [pid 14039:tid 139635342628608] [client 174.93.3.150:19979] /home/theoverg/arcadeholics.net/Games/.htaccess: RewriteOptions: unknown option 'maxredirect=10', referer: https://arcadeholics.net/index.php?action=arcade;sa=play;game=13;reload=8634;
[Sun Sep 13 17:09:30.591159 2020] [core:alert] [pid 14038:tid 139635174774528] [client 174.93.3.150:19719] /home/theoverg/arcadeholics.net/Games/.htaccess: RewriteOptions: unknown option 'maxredirect=10', referer: https://arcadeholics.net/index.php?action=arcade;sa=play;game=12;reload=2599;
[Sun Sep 13 17:09:25.476429 2020] [core:alert] [pid 14039:tid 139635157989120] [client 174.93.3.150:19391] /home/theoverg/arcadeholics.net/Games/.htaccess: RewriteOptions: unknown option 'maxredirect=10', referer: https://arcadeholics.net/index.php?action=arcade;sa=play;game=13;reload=8634;
[Sun Sep 13 17:09:20.882695 2020] [core:alert] [pid 14039:tid 139635157989120] [client 174.93.3.150:19139] /home/theoverg/arcadeholics.net/Games/.htaccess: RewriteOptions: unknown option 'maxredirect=10', referer: https://arcadeholics.net/index.php?action=arcade;sa=play;game=15;reload=8610;
AH00112: Warning: DocumentRoot [/home/theoverg/theover50goldengroup.net] does not exist
AH00112: Warning: DocumentRoot [/home/theoverg/theover50goldengroup.net] does not exist
[Fri Sep 11 09:04:22.603820 2020] [access_compat:error] [pid 2295:tid 140558282475264] [client 31.22.4.46:59393] AH01797: client denied by server configuration: /home/theoverg/arcadeholics.net/tp-downloads/

I also have a arcadeholics test board


Chen Zhen


The maxredirect=10 is something I tried a few days ago and it is already removed.

I don't see anything else related to the arcade
The upload script works on 2 local test forums (SMF 2.1 & SMF 2.0).
It works here on this forum (SMF 2.1) and I just tested it on doc skhills (smf 2.0).
All of them are using RC7 for the latest arcade version.


Imo something is not right with your Apache settings.
Also note that having a test forum in a child directory of that forum will cause cookie problems for both forums.
I've been through that myself.

Ronald

Quote from: Chen Zhen on September 15, 2020, 07:40:52 PMThe maxredirect=10 is something I tried a few days ago and it is already removed.

I don't see anything else related to the arcade
The upload script works on 2 local test forums (SMF 2.1 & SMF 2.0).
It works here on this forum (SMF 2.1) and I just tested it on doc skhills (smf 2.0).
All of them are using RC7 for the latest arcade version.


Imo something is not right with your Apache settings.
Also note that having a test forum in a child directory of that forum will cause cookie problems for both forums.
I've been through that myself.


OK I'll remove the test board.

Chen Zhen

September 15, 2020, 09:15:41 PM #9 Last Edit: September 15, 2020, 09:18:33 PM by Chen Zhen Reason: alllllll
I can tell you removed the sub-directory forum already as I just uploaded & installed 2 games on your forum without a problem.

This very same thing happened to me.
I used to be able to have child test forums off of the main one in the past but Imo something with how SMF does their cookies won't allow it without problems.
You can play around with the cookie settings all you want but it won't work properly.
The best way to have test forums that works is to create new forums in your DNS, Apache config settings & registrar.
My current VPS host allows me to create/control my own reverse DNS entries as well which is great.

Other than that you can just do local testing.
I use Wampserver where I updated the SSL, MariaDB & PHP to current for proper testing.